Resolved
The issue with increased processing times is now resolved. Impacted services have returned to normal operation.
Monitoring
A service degradation earlier today has caused some processing delays across Scorecards, CQL Reports and Catalog Discovery. The issue has been mitigated and processing is now catching up. We will continue to update this page until it is fully resolved.