Resolved
The issue with increased latency has been resolved. Impacted services have returned to normal operation.
Monitoring
The issue with increased latency has been identified and mitigated. We are monitoring the performance of impacted services. We will continue to update this page until it is resolved.
Investigating
We are investigating a service disruption with increased latency that may impact some customers. Please continue to monitor this page for updates.